telnet hanging

Matthew Davy mpd at
Mon Oct 14 21:47:27 UTC 2002

I've had problems with telnet and ssh hanging on certain routers for a while 
now.  Seems to get better or worse depending on what version of IOS we're 
running.   (Incidentally, I haven't seen any problems with Junipers).  Last 
week it started hanging on the same router about every other time I ran a diff.

I saw a note about a possible expect bug on Linux, but I couldn't get the older
version which was posted on the rancid page to build and I upgraded to the 
newest versions of expect and tcl and it didn't fix it either.    
I installed the same versions of rancid (2.2.2), expect (5.38) and tcl (8.3) 
on a FreeBSD box last Friday and have been running diffs every hour since 
without a problem.

- Matt

On Mon, Oct 14, 2002 at 05:19:27PM -0400, jlewis at wrote:
> I've installed rancid-2.2.2 on a Red Hat 7.2 system and have noticed a 
> problem where telnet (spawned from clogin) hangs on one particular router 
> (the first in router.db).  When I check the router, the telnet session has 
> successfully logged in and is just sitting idle.  I've seen it hung for as 
> much as an hour before I've killed the telnet process.
> I did a quick search of the archive and didn't see anyone reporting 
> something similar.  Anyone seen/solved this before?
> ----------------------------------------------------------------------
>  Jon Lewis *jlewis at*|  I route
>  System Administrator        |  therefore you are
>  Atlantic Net                |  
> _________ for PGP public key_________

More information about the Rancid-discuss mailing list