False unreachable?

john heasley heas at shrubbery.net
Tue Jun 3 20:43:53 UTC 2003

doesnt make sense.  just to review the obvious...
	- you tried it manually as the user who runs rancid
	- your manual attempt used telnet and not ssh
	- your path and/or environment matches that of the rancid user
	  (no goofy telnet executable or kerberos ...)

otherwise, i would disable the do-diffs cron job, edit bin/rancid-fe
and place -d after the device's rancid script, eg:

< elsif ($vendor =~ /^cisco$/i)           { exec('rancid', $router); }
> elsif ($vendor =~ /^cisco$/i)           { exec('rancid', '-d', $router); }

and set NOPIPE=YES in bin/env, then run bin/do-diffs <group name>

this way, the .raw file will remain behind and can be further examined.

warning: this will cause zero-ing/truncation of any configs that fail to
be collected.  of course, it will be corrected on the next successful run.

Tue, Jun 03, 2003 at 04:01:13PM -0400, Ted Bedwell:
> That worked beautifully. my.devce.new has the config in it. However, it
> still is not working when the do-diffs runs.
> ~~ted

More information about the Rancid-discuss mailing list