Problems running do-diffs on Foundry

john heasley heas at
Tue Feb 17 04:10:06 UTC 2004

Mon, Feb 16, 2004 at 08:23:38PM -0500, Eric Van Tol:
> Hi all,
> We currently have Rancid set up to backup three Foundry ServerIron
> switches and do-diffs cannot seem to log into one of them.  When I run
> flogin, everything works just fine, but when it's run using 'do-diffs',
> the session times out.  Here is a logfile snippet from the do-diffs:
> Trying to get all of the configs.
> !
> slb02: flogin error: Error: TIMEOUT reached
> slb02: missed cmd(s): write term,show flash,show module,show
> chassis,show version
> slb02: End of run not found
> =====================================
> Getting missed routers: round 1.
> Why would flogin be able to log in when run independently of do-diffs?
> The two Foundry switches that are working are running 07.3.06T12 and the
> one that is not working is running 07.1.21T12.  I've tried using both
> SSH and telnet as the method on this particular switch.  
> Any ideas?

Does the following run successfully?

	flogin -c 'show version;show chassis' host

More information about the Rancid-discuss mailing list