timeout on extreme switches

Bostjan Fele bostjan.fele at guest.arnes.si
Sat Feb 21 09:35:08 UTC 2004


Tried to go deeper with clogin. Machine prompts back with "TESTIRNICA-BD:1

$ clogin bd -c "show version"
spawn telnet bd
Connected to bd.
Escape character is '^]'.
login: nmis

Copyright (C) 1996-2003 Extreme Networks.  All rights reserved.

Press the <tab> key at any time for completions.
Remember to save your configuration changes.
Error: TIMEOUT reached

That is already "enabled" prompt in Cisco terms. Here my .cloginrc config
for this device:

# BlackDiamond
add user     bd      nmis
add password bd      nmis
add noenable bd 1


-----Original Message-----
From: john heasley [mailto:heas at shrubbery.net]
Sent: Saturday, February 21, 2004 9:20 AM
To: Bostjan Fele
Cc: Rancid-Discuss at Shrubbery. Net
Subject: Re: timeout on extreme switches

Sat, Feb 21, 2004 at 08:48:05AM +0100, Bostjan Fele:
> Hi,
> Have a running FreeBSD 4.9 with rancid 2.3r1_1 and am trying to collect
> configs from Extreme Switches. When I use clogin to test I get through
> procedure but cannot issue any command - don't get responses back. It does
> not matter if logged in through telnet or SSH.
> If I run xrancid it complains about expired timeout. Any idea what is
> wrong?
> # xrancid bd
> bd clogin error: Error: TIMEOUT reached
> bd: missed cmd(s): show configuration,show diagnostics,show memory,show
> slot,show switch,show configuration detail,show version
> bd: End of run not found
> #

most often this is a problem with matching of the prompt.  either
the device "auto enables" or aaa has been used to alter the prompt.

when you login manually, what does the prompt look like?

More information about the Rancid-discuss mailing list