cisco 9509 fiber switch not working

Hopper, Faron W. faron.hopper at
Wed Dec 14 20:13:05 UTC 2005

	Platform = freebsd 5.4
	Rancid ver = rancid-2.3.1_1
	Expect ver = expect-5.43.0

>> Have you tried "rancid -d" to get debug output?

Yes, that is how I attached the .raw and .new files.  I attached them
and the info from the log file.  Is there anything else that would give
me more information?

Another user on the list, Mark Scheuber, responded with

"I wound up hacking the script with 'show running-config'   =>
"WriteTerm", and changing the text of the actual command in the array
below that..  Very dirty, I know, but it works.  I think I also might
have done a few more tweaks that stripped off the error correction.  If
I remember correctly there was some white space at the end, and a prompt
issue that was throwing the scripts.  Also, the snmp server settings
change hourly depending on if the people configuring the SAN use that
little java applet.  Just an FYI as it threw me while I was working on
        The major problem I had was setting up the escalated privileges
in ACS as we have an EMC branded box, but after locating the actual
documentation on Cisco's site versus EMC I was set.  Let me know if you
want the script I hacked together, but again, it's not pretty. ..."

He is willing to send me the script, and I will try to pursue that
avenue next, unless you have another idea.


-----Original Message-----
From: Ed Ravin [mailto:eravin at]
Sent: Wednesday, December 14, 2005 11:56 AM
To: Hopper, Faron W.
Cc: rancid-discuss at
Subject: Re: cisco 9509 fiber switch not working

On Wed, Dec 14, 2005 at 12:33:03PM -0500, Hopper, Faron  W. wrote:
> Hello all,
>      I have a cisco 9509 fiber switch that I can't get rancid to
> recognize.  I can clogin -c "show version" to it and it provides the
> show version command and then exits.  When I try to run a rancid-run
> device to it, it produces the following log file
> ==============================================================
> starting: Wed Dec 14 10:55:06 CST 2005
> Trying to get all of the configs.
> cod-cisco-9509-1: End of run not found


What platform are you using, and what version of RANCID?  Also, read the
release notes in RANCID about how some versions of Expect need to be

Have you tried "rancid -d" to get debug output?

Sometimes this error means rancid didn't find the last command ("exit"),
in your case, it's there at the end of the output:

  Connection closed by foreign host.

> The .raw file makes me think that it can't parse the error from the
> write term command (which is not supported on this device).

That's not the problem - you'll note that "show running-config" was
also sent and recognized.  rancid is smart enough to use whichever one

More information about the Rancid-discuss mailing list