[rancid] Re: SVN backend

john heasley heas at shrubbery.net
Tue Feb 19 17:06:56 UTC 2008

Tue, Feb 19, 2008 at 09:03:46AM -0800, Nate Beck:
> All,
>   I have 2.3.2a8 installed on rhel5.  I enabled svn on install and set the
> rancid.conf to use svn also. But whenever rancid-run goes I get the
> following error in the log
> Trying to get all of the configs.
> All routers sucessfully completed.
> Sending        .
> svn: Commit failed (details follow):
> svn: Out of date: '/networking' in transaction '5-1'
> ending: Tue Feb 19 05:47:00 GMT 2008
> And everytime it runs, it mails me the complete config since it has not
> committed it to the repository.  I tried running svn update and it says that
> it is current.
> Any ideas on how to fix this?

I havent tried svn for a while, but none of that code has changed.  I'd
guess that someone has been mucking about in there.  go to the networking
dir and 'svn update' and correct any complaints it may have.

More information about the Rancid-discuss mailing list