[rancid] Re: Incomplete output

Martin, Seth SMartin at sourceinterlink.com
Wed Jul 9 18:02:19 UTC 2008

Are you sure you are getting logged into the device with the appropriate
privilege level?  


What if you just use ./clogin devicename does it give you an enable
prompt, and if so can you execute the show run command then manually
from the prompt it gives you?


Seth Martin 


From: rancid-discuss-bounces at shrubbery.net
[mailto:rancid-discuss-bounces at shrubbery.net] On Behalf Of Justin
Sent: Wednesday, July 09, 2008 1:56 PM
To: rancid-discuss at shrubbery.net
Subject: [rancid] Incomplete output


I am trying to set up rancid and must be missing something simple.  This
is a manual run with clogin using expect 5.43 compiled with the
expect-hack1.  Destination switch is a Cisco 3020 (blade chassis


~$ clogin -t 90 -c"show running-config write term""


The output I get for both commands is:

Building configuration...


Current configuration : 159 bytes


! Last configuration change at 18:07:19 EDT Wed Jul 9 2008 by jlambert

! NVRAM config last updated at 13:40:03 EDT Wed Jul 9 2008 by jlambert









I tried adding 'terminal length 0' to the start of the clogin command
hoping maybe that would be sufficient to print out the whole config
without hanging on a 'more', but to no avail.  I ran expect -d <....>
and didn't see anything in the output that looked wrong.   Is this
related to the expect issues that for some reason are still manifesting
itself on my machine?  I have tried this on my gentoo machine and on a
CentoOS 5.2 machine.




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20080709/8f1ed719/attachment.html 

More information about the Rancid-discuss mailing list