[rancid] Foundry ServerIron

William Yardley rancid at veggiechinese.net
Tue May 12 01:26:21 UTC 2009

A few questions about getting a Foundry ServerIron setup and working
with Rancid....

First, I have the following in .cloginrc:

add user hostname.example.com rancid
add password hostname.example.com [thepassword]
add method hostname.example.com ssh
add autoenable hostname.example.com 1

The user is connecting as a user which already should have the necessary
permissions; I first tried:
add noenable hostname.example.com 1

but then, if I run 'flogin hostname.example.com', I get:
Error: no enable password for hostname.example.com in /var/rancid/.cloginrc.

 'clogin hostname.example.com' or
 'flogin -noenable hostname.example.com'

works as expected (i.e., I get to the router's prompt). Is this a bug or
am I just trying to do things the wrong way? And in this case (using a
user account with appropriate privs), is 'noenable' or 'autoenable' what
I want?

So far, I can login Ok with clogin / flogin (with the caveat above), but
for whatever reason, after switching from 'noenable' to 'autoenable',
I'm getting the following in the logs if I try to do a run:
  Trying to get all of the configs.
  hostname.example.com flogin error: Error: TIMEOUT reached
  hostname.example.com: missed cmd(s): show chassis,show module,show flash,show version,show running-config,write term
  hostname.example.com: End of run not found

I notice that flogin is trying to run the following commands:
show version;show chassis;show module;show flash;write term;show running-config

Will it fail if some of these don't work? write term and show module
don't work for me (not as the user I'm connecting as, and I believe not
at all).


More information about the Rancid-discuss mailing list