[rancid] Rancid 2.3.4 with Extreme XOS - Black Diamonds

Patty Luxton pluxton at antracnetworks.com
Mon Nov 29 19:44:35 UTC 2010

I've seen several posts regarding clogin not working correctly with the
8810s, however, I never saw a solution posted for this problem.  So I
apologize if this is a duplicate problem surfacing again that has already
been solved.

We are running rancid version 2.3.4 with expect version 5.43.0-5.1, and have
rancid installed on Linux.

We have successfully deployed rancid for Cisco, Netscreen, Netscaler, and a
few others, including Extreme 48si's with Extremeware on it.

However, I am unable to get clogin to work with the Black Diamonds with XOS.

It seems as if an extra carriage return is getting submitted, causing
nothing to be input for the password, but then the password gets used for
the next login attempt:


[rancid at lhr2-mgmt-net-01 ~]$ bin/clogin device.name
spawn telnet device.name
Connected to device.name.
Escape character is '^]'.

telnet session telnet0 on /dev/ptyb0

login: rancid.user

Login incorrect
login: rancid.password

Login incorrect
login: rancid.password <mailto:R at ncidConfigs> 

Login incorrect
Maximum number of login attempts reached!
Connection closed by foreign host.

Error: Connection closed (telnet): device.name


Since our passwords have characters in it, I've tried clearing those out,
but it make no difference.  I've tried multiple changes to the .cloginrc,
including curly brackets around passwords, usernames, and have added the
autoenable line.  I've even tried to add the login and password prompt
arguments to the .cloginrc, but no change.

Is there a solution for this problem that I have not seen yet?


Thank you,




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20101129/2eead260/attachment.html>

More information about the Rancid-discuss mailing list