[rancid] Rancid 2.3.4 with Extreme XOS - Black Diamonds

Patty Luxton pluxton at antracnetworks.com
Tue Nov 30 22:07:25 UTC 2010

I've attached the output from the clogin -d.  Note that the username is
lax\blackd.user - radius had been set up on a windoze domain.  I've tried
using a local login and get the same results.  This format is working okay
for all our other devices, provided that I put {} around the username in the
.cloginrc file, so I'm hoping it's not the username that's the problem.
I've seen an online post where you may have seen this problem before - it
seems the person having the problem decided to use jlogin instead of clogin.
That works for logging in, but then it hangs after it logs in, as if it
didn't see the final prompt that it expected.  So if I go the jlogin route,
I'll need to modify the jlogin script to accommodate this.
Thanks in advance for any help you provide.

-----Original Message-----
From: john heasley [mailto:heas at shrubbery.net] 
Sent: Tuesday, November 30, 2010 11:49 AM
To: Patty Luxton
Cc: rancid-discuss at shrubbery.net
Subject: Re: [rancid] Rancid 2.3.4 with Extreme XOS - Black Diamonds

Mon, Nov 29, 2010 at 11:44:35AM -0800, Patty Luxton:
> I've seen several posts regarding clogin not working correctly with 
> the 8810s, however, I never saw a solution posted for this problem.  
> So I apologize if this is a duplicate problem surfacing again that has 
> already been solved.
> We are running rancid version 2.3.4 with expect version 5.43.0-5.1, 
> and have rancid installed on Linux.
> We have successfully deployed rancid for Cisco, Netscreen, Netscaler, 
> and a few others, including Extreme 48si's with Extremeware on it.
> However, I am unable to get clogin to work with the Black Diamonds with
> It seems as if an extra carriage return is getting submitted, causing 
> nothing to be input for the password, but then the password gets used 
> for the next login attempt:
> [rancid at lhr2-mgmt-net-01 ~]$ bin/clogin device.name

try clogin -d to what is really being sent for the username.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: lhr2-8810.log
Type: application/octet-stream
Size: 59739 bytes
Desc: not available
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20101130/43cfe886/attachment.obj>

More information about the Rancid-discuss mailing list