[rancid] rancid 2.3.6: clogin with multiple devices fails... ($autologin not defined)

Lee ler762 at gmail.com
Fri Jun 24 00:09:48 UTC 2011


On 6/23/11, Jon Peatfield <J.S.Peatfield at damtp.cam.ac.uk> wrote:
> On Mon, 13 Jun 2011, Jon Peatfield wrote:
>> I originally thought that this might be a config error on my part but
>> currently for me with rancid 2.3.6 I can happily run:
>>  clogin -c 'some-command' router1
>> or
>>  clogin -c 'some-command' router2
>> but not:
>>  clogin -c 'some-command' router1 router2
> <snip>
>> At the moment I can just use a shell script to loop over each device and
>> so
>> avoid listing multiple hosts on the clogin command, but I was very
>> surprised
>> by it not doing what I expected - since I'd used an almost identical
>> command
>> with hlogin a few days earlier.
> <deathly quiet>
> So is this something specific to my copy of rancid, or is this just a well
> known thing to be avoided?

I'd never tried it before, so I stayed quiet :)   But it's easy enough
to test, so
  clogin -c "sh ip eigrp int"  router1 router2 router3 ... router20
worked for me using rancid 2.3.6


More information about the Rancid-discuss mailing list