[rancid] Need some Help - F5's in RANCID

Ben O'Hara bohara at ripe.net
Wed Jun 29 13:47:21 UTC 2011

On 28 Jun 2011, at 09:36, Jethro R Binks wrote:

> On Mon, 27 Jun 2011, Lee wrote:
>> After seeing that the regularly scheduled rancid run failed to get
>> several F5 configs this morning I ran it manually:
>> export NOPIPE=YES
>> rancid-run F5
>> rancid collected all the configs & no errors in the log.  Crontab
>> kicked off the rancid run later in the day & several F5s showed up in
>> the log with the
>> missed cmd(s): ls --full-time --color=never /config/ssl/ssl.crt,ls
>> --full-time --color=never /config/ssl/ssl.key
>> again, run rancid manually with NOPIPE=YES and everything works.
>> Any thoughts on how to debug the problem would be appreciated since
>> the standard debugging suggestion is to set NOPIPE and use the -d
>> option.  I have yet to see rancid fail to get an F5 config if nopipe
>> is set
> In that case, in rancid.conf you can set NOPIPE permanently:
> # if NOPIPE is set, temp files will be used instead of a cmd pipe during
> # collection from the router(s).
> Does that help?

We've been seeing the same problem with 2 f5s running 10.2.1

others running 10.2.0 are fine.

Again, it also works fine when run manually, just not when running normally.

Tried setting NOPIPE=yes but the problem still persists.


Ben O'Hara                        RIPE Network Coordination Center
Senior Systems Engineer                  Singel 258, Amsterdam, NL
http://www.ripe.net                                +31 20 535 4444
PGP Fingerprint: 080A 52FF BF0A A7FB F176 E7DB 513D 9A3D E968 7DBC

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 1731 bytes
Desc: not available
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20110629/0731311f/attachment.bin>

More information about the Rancid-discuss mailing list