[rancid] Rancid doesn't update some files

Jevos, Peter Peter.Jevos at oriflame.com
Tue Mar 29 15:00:20 UTC 2011

i'm using rancdid for a months

however some routers were suddenly stoped to updating
I'm using the comnnand 'show configuration' to download the config

when i run ./clogin command with the show config commnand, it displays cuurent config

However when i run rancid-run, it stores not a current config and shows no changes
Part of the rancid file is:
   #       {'show vlan'                    => 'ShowVLAN'},
#       {'show vlan-switch'             => 'ShowVLAN'},
#       {'show debug'                   => 'ShowDebug'},
        {'more system:running-config'   => 'WriteTerm'},        # ASA/PIX
        {'show configuration'           => 'WriteTerm'},
        {'write term'                   => 'WriteTerm'},

Where can be a problem?
In rancid or CVS ?



I've found out, that when I debug it with ./rancid command, it creates .new and .raw file

.raw file is correct, but the .new file is not

What does it mean?


More information about the Rancid-discuss mailing list