[rancid] Rancid CVS Issue

Nicolai Langfeldt Nicolai.Langfeldt at ventelo.no
Wed Mar 7 09:16:35 UTC 2012


I note that "echo $BASEDIR" is rather useless, but it's not meant to be useful in the rancid users shell.

Also $BASEDIR should _not_ be quite identical to your rancid install prefix, IMHO at least it's rather messy.  If you want it to be within your install prefix at least put it in a subdir such as /usr/local/rancid/backups or somesuch.

Try this:
- cd to the $BASEDIR as defined in rancid.conf (not quite sure if this is required, I just always do it)
- rancid-cvs networking

Fra: Andy Townsend [me at andytownsend.co.uk]
Sendt: 7. mars 2012 10:07
Til: Nicolai Langfeldt
Kopi: rancid-discuss at shrubbery.net
Emne: Re: [rancid] Rancid CVS Issue

I've already got this in rancid.conf

# list of rancid groups

And when I run /usr/local/rancid/bin/rancid-cvs I get no output.

[rancid at router ~]$ /usr/local/rancid/bin/rancid-cvs
[rancid at router ~]$

[rancid at router ~]$ echo $BASEDIR

[rancid at router ~]$ pwd
[rancid at router ~]$ ls -l
total 60
drwxr-xr-x 2 rancid netadm  4096 Mar  6 17:26 bin
drwxr-xr-x 2 rancid netadm  4096 Mar  7 09:04 etc
-rw-r--r-- 1 rancid netadm 12738 Mar  6 17:22 README
drwxr-xr-x 4 rancid netadm  4096 Mar  6 17:13 share
drwxr-xr-x 3 rancid netadm  4096 Oct 26 21:51 tar
drwxr-xr-x 5 rancid netadm  4096 Mar  6 17:21 var

I believe there should be a CVS directory in there. I did install CVS after rancid so I guess that may have caused the issue. Any ideas?


On 6 March 2012 19:44, Nicolai Langfeldt <Nicolai.Langfeldt at ventelo.no<mailto:Nicolai.Langfeldt at ventelo.no>> wrote:
I expect you either forgot to update rancid.conf so that it reads:


Or you already did rancid-cvs?

Fra: rancid-discuss-bounces at shrubbery.net<mailto:rancid-discuss-bounces at shrubbery.net> [rancid-discuss-bounces at shrubbery.net<mailto:rancid-discuss-bounces at shrubbery.net>] p&#229; vegne av Andy Townsend [me at andytownsend.co.uk<mailto:me at andytownsend.co.uk>]
Sendt: 6. mars 2012 18:45
Til: rancid-discuss at shrubbery.net<mailto:rancid-discuss at shrubbery.net>
Emne: [rancid] Rancid CVS Issue


I've just installed rancid on one of my boxes following the guide here.


However, when I run the rancid-cvs command, I get no output.

[rancid at router ~]$ /usr/local/rancid/bin/rancid-cvs
[rancid at router ~]$

When as per the docs I should be getting this.

[rancid at bigboy ~]$ /usr/local/rancid/bin/rancid-cvs
No conflicts created by this import
cvs checkout: Updating networking
cvs checkout: Updating networking/configs
cvs add: scheduling file `router.db' for addition
cvs add: use 'cvs commit' to add this file permanently
RCS file: /usr/local/rancid//var/CVS/networking/router.db,v
Checking in router.db;
/usr/local/rancid//var/CVS/networking/router.db,v   <--   router.db
initial revision: 1.1

CVS is already installed so no issues there,

[rancid at router ~]$ rpm -qa | grep cvs

Just wondering if anyone had come across this or know what the next steps were?


More information about the Rancid-discuss mailing list