[rancid] F5 BIG-IP devices - any tricks?

Ryan West rwest at zyedge.com
Tue May 15 00:56:20 UTC 2012

On Mon, May 14, 2012 at 17:58:45, Colin Stubbs wrote:
> discuss at shrubbery.net
> Subject: Re: [rancid] F5 BIG-IP devices - any tricks?
> What O/S or distro you running RANCID on? Expect versions? BIGIP versions?
> etc

Debian 6.0.5, compiled expect 5.45, RANCID 2.3.8, LTM 11.0.0/10.2.3/10.2.0/10.0.1/9.4.8

It always works with rancid-run -r for that device, but never completes a normal run unless the 'ls -al' command is stripped.

> I've seen the same thing back on EL3/4 a few years ago. Mostly rancid 
> used to have issues with the ls /config/ssl/ssl.xxx commands for me.
> Again, I either commented them out, or replaced the command with 
> something else that worked without issue (a script on the F5 that did 
> the same thing at one point).
> I havn't had any issues for quite awhile though, mostly since moving 
> away from EL3/4 and using EL5/6 in production and Fedora 14/15/16 at home.
> On 14 May 2012 22:24, Ryan West <rwest at zyedge.com> wrote:
> > Comment those lines out, they have never worked for me. I've 
> > recompiled expect for the bug and it doesn't seem to help.
> >

More information about the Rancid-discuss mailing list