[rancid] Rancid and Nortel 8600

AJ Schroeder AJ.Schroeder at directsupply.com
Fri Nov 1 18:41:00 UTC 2013

I'm not a  guru, but from what I can tell rancid or expect is having issues processing the login sequence and then just sits there. Here is a snippet from a debug of blogin command (for reference, the command I ran is "blogin -t 90 -c "show config;show config -all;exit" switch.example.com"):

expect: set expect_out(0,string) "password:"
expect: set expect_out(1,string) "password"
expect: set expect_out(spawn_id) "exp4"
expect: set expect_out(buffer) "rwa at switch.example.com's password:"
send: sending "rwa\r" to { exp4 }
Gate keeper glob pattern for '[Pp]assword:' is '?assword:'. Activating booster.

expect: does " " (spawn_id exp4) match regular expression "[Pp]assword:"? Gate "?assword:"? gate=no
">"? no

expect: does " \r\n" (spawn_id exp4) match regular expression "[Pp]assword:"? Gate "?assword:"? gate=no
">"? no

expect: does " \r\n\r\nERS-8600:5# " (spawn_id exp4) match regular expression "[Pp]assword:"? Gate "?assword:"? gate=no
">"? no
expect: timed out

Error: TIMEOUT reached

After the timeout is reached, I am logged out of the switch.



-----Original Message-----
From: rancid-discuss-bounces at shrubbery.net [mailto:rancid-discuss-bounces at shrubbery.net] On Behalf Of heasley
Sent: Wednesday, October 30, 2013 5:19 PM
To: Alan McKinnon
Cc: rancid-discuss at shrubbery.net
Subject: Re: [rancid] Rancid and Nortel 8600

Wed, Oct 30, 2013 at 08:27:12AM +0200, Alan McKinnon:
> Hi AJ,
> That would explain it.
> It's most unusual that it happens when brancid is running though, as 
> it's not idle, it's running commands in rapid succession. Tuning back 
> the timeout settings on the switch will probably solve your issue as 
> everything else you mention looks fine.
> For troubleshooting things like this, I find
> brancid -d <hostname>
> very useful. It dumps the entire *login command to the console where 
> you can copy-paste it and run it repeatedly, plus lots of error output.
> On 29/10/2013 16:53, AJ Schroeder wrote:
> > Alan,
> > 
> > Thanks for the reply. I ran blogin manually against the device and it logs me right in, however after letting it idle about 30 seconds I get the TIMEOUT reached message:

its not completing the login - its not matching the prompt that its looking for, it'd gone into interactive mode at this point and you'd be able to type at the prompt.

blogin -d host  will help you debug.

> > rancid at linux-server:~> bin/blogin host.example.com host.example.com 
> > spawn ssh -c 3des -x -l rwa host.example.com rwa at host.example.com's 
> > password:
> > 
> > Nortel8600:5#
> > Error: TIMEOUT reached
> > rancid at linux-server:~>
Rancid-discuss mailing list
Rancid-discuss at shrubbery.net

More information about the Rancid-discuss mailing list