[rancid] Vyatta config processing.

Matthew MacAulay mat.macaulay at gmail.com
Tue Sep 24 14:22:32 UTC 2013

Hello list,

I am new to Rancid and have found it to be excellent when working with
Cisco devices. I have also managed to get it looking after NXOS, Alteon,
Foundry and F5 without too many problems. Most answers I found here J

I have one device left on my mission list.

A vyatta router, there are a couple of scripts / modules out there and I
have tried to make them work but I am stuck and need some help.

This one seems most promising as it followed the normal rancid module


The default commandtable command did not work for me, the prompt logs in
fine and run’s the ‘show configuration’ commands, but it needs an “any key”
pressing to display all of the config.. I have tried and failed to make
this work, I think I need to change my prompt to be a large number or lines
or something?

Either way, it would seem that there is a better command that should be
used, so I changed my commandtable

@commandtable = (

{'cli-shell-api showConfig --show-active-only' => 'WriteTerm'},


All I get back checked into CVS are the interfaces (top bit of the config),
I am thinking that the sub WriteTerm is detecting the End of the config
early but spotting this beyond my perl skills.

If I run the command below I get the full config.

/usr/lib/rancid/bin/clogin -f /var/lib/rancid/.cloginrc -c "cli-shell-api
showConfig --show-active-only" vyattaR1

Below is the first bit of the config, it stops after the loopback
interface, can anyone tell me why and what I need to do to fix it?

Thanks inadvanced.




    ethernet eth1 {


        duplex auto

        hw-id 00:50:56:e0:00:18

        smp_affinity auto

        speed auto

        vrrp {

            vrrp-group 20 {

                advertise-interval 1

                preempt true

                priority 101

                sync-group ALPHA





    loopback lo {


}     <--------- Rancid stops processing the config here..

protocols {

    bgp 12345 {

        neighbor {

            allowas-in {


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20130924/555df190/attachment.html>

More information about the Rancid-discuss mailing list