[rancid] "rancid -d <devicename>" works, but "rancid-run <groupname>" does nothing

Olivier Boudry olivier.boudry at gmail.com
Wed May 14 09:19:18 UTC 2014


I just installed rancid 2.3.8 and configured it as described in

I can get bin/clogin to work for all my devices. bin/rancid -d will also
work and create me a localfile called devicename.new and containing the
full configuration, but when I try to run the full group of devices "gb1",
nothing happens.

The group is defined in etc/rancid.conf as LIST_OF_GROUPS="gb1"
(uncommented). I ran rancid-cvs which created the var/gb1 folder, and
edited var/gb1/router.db which looks like this:|cisco|up|cisco|up|cisco|up|cisco|up

Running "rancid-run gb1", or simply "rancid-run" has no effect. In the log
I find the following:

starting: Wed May 14 09:52:28 BST 2014

ending: Wed May 14 09:52:28 BST 2014

But if I run directly "bin/rancid", it works and I get the
config in

Any idea what could go wrong and how I could troubleshoot this?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20140514/7f34a234/attachment.html>

More information about the Rancid-discuss mailing list