[rancid] clogin issue

yann.moren at bluewin.ch yann.moren at bluewin.ch
Mon Sep 1 14:28:35 UTC 2014

Hi all,
I've recently installed and configured Rancid on a server and i have a really boring issue when trying to run clogin "device name".
When i try to test loging in, it may work 1 or 2 times but for a 3rd attempt i've got the following error:
rancid at srv-rancid01:/var/lib/rancid/bin$ ./clogin aog_benin_petrol
spawn telnet aog_benin_petrol
Connected to AOG_Benin_Petrol.
Escape character is '^]'.
!!!   RESTRICTED AREA    !!!
-----> Disconnect Now <-----
User Access Verification
Username: enable
% Authentication failed
Username: vsat
% Authentication failed
Username: vsat
% Authentication failed
Connection closed by foreign host.
Error: EOF received
can not find channel named "exp6"
    while executing
"send "\r""
    ("foreach" body line 150)
    invoked from within
"foreach router [lrange $argv $i end] {
    set router [string tolower $router]
    # attempt at platform switching.
    set platform ""
    send_user ..."
    (file "./clogin" line 758)
It is sending the enable command before sending the username and password. Or maybe was it already sent but not received by the device. I tried to deactivate autoenable but no improvement.
I have to say i'm lost. I tried to look into expect and use different package version as well as with Rancid with always the same result. The parsing seems not to work correctly. Could it be related to the latency? A majority of devices from which i want to get the configuration are over satellite links.
Thanking you for support.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20140901/91bcc61d/attachment.html>

More information about the Rancid-discuss mailing list