[rancid] cisco 4516 backup issue

Daren McGill dmcgill at youngliving.com
Wed May 6 19:22:07 UTC 2015

So I have followed all of the trouble shooting steps in the FAQ as stated below. If I run the following command all works well and I get the file and output I am looking for rancid -d -t cisco slc-core02. If I run the rancid-run -r slc-core02 I get the following in the log message

slc-core02: missed cmd(s): all commands
slc-core02 clogin error: Error: Connection closed (ssh): slc-core02
slc-core02: End of run not found

This was working with no issues and now has not been backing up. It is still working for all other routers in the router.db the entry for these is simple and should be fine slc-core02;cisco;up any advice or options to try and get this working again would be appreciated.


Q. I have a (set of) device(s) on which collection fails.  How can I debug
A. Our usual diagnostic procedure for this is:
   - Make sure that the appropriate *login (example: clogin for cisco) works.
     This tests to make sure you don't have routing or firewall issues, DNS
     or hostname errors, that your .cloginrc is correct, your banner does
     not have some character that *login does not like, and that the *login
     script doesn't have a bug of some sort.  For example:

        clogin cisco_router

     Should login to cisco_router and produce a router prompt that you can
     use normally, as if clogin were not used (i.e.: telnet cisco_router).

   - See if commands can be executed on the router via clogin.  This will
     exercise the *login functionality needed for rancid.  For example:

        clogin -c 'show version; show diag' cisco_router

     Should login to cisco_router, run show version and show diag, then
     disconnect and exit.  The output will be displayed on your terminal.

   - Then see if the correct rancid commands work against the router.  For

        rancid cisco_router

     Should produce a cisco_router.new file (cooked to a golden rancid-style
     colour) in the current directory.  If it does not, try again with the
     -d option, so that the cisco_router.new file will not be removed if
     an error is detected.  Note: if you have NOPIPE set in your environment,
     a cisco_router.raw file will be produced that is the raw output of the
     dialogue with the device.

   If all of these work, make sure that the device's entry in the group's
   router.db file is correct and check the group's last log file for errors.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20150506/05a65bc9/attachment.html>

More information about the Rancid-discuss mailing list