[rancid] Old lockfile still exists

Gerhard Mourani gmourani at gmail.com
Wed May 13 14:27:04 UTC 2015

Seem to be ok. If I run each one manually with command like -> /usr/bin/rancid-run -r x.x.x.x it work!
But when I run them with -> /usr/bin/rancid-run Fortinet, then the process never end!
strace /usr/bin/rancid-run Fortinet never finish.

Can see the following in the log: cvs status: [13:41:26] waiting for rancid's lock in /var/lib/rancid/CVS/Fortinet/configs

> On May 13, 2015, at 9:17 AM, heasley <heas at shrubbery.net> wrote:
> Wed, May 13, 2015 at 09:08:05AM -0400, Gerhard Mourani:
>> Hello List,
>> Since a week ago I’ve started to receive this message every time the rancid script run to get backups.
>> Old lockfile still exists:
>> -rw-r----- 1 rancid rancid 0 May 12 12:01 /tmp/.Fortinet.run.lock
>> The above happen only for Fortigate devices and not for the other (Cisco, Brocade, etc..) which work fine.
>> Even if I remove the /tmp/.Fortinet.run.lock file, the next time the script run the problem happen again!
>> Someone have an idea about how to fix it?
> it must be hanging on one or more of those devices.  ktrace/strace the
> processes to see what theyre doing.

More information about the Rancid-discuss mailing list