[rancid] RANCID/clogin context-change FWSM/ASA

Christian Filips chr.filips at googlemail.com
Tue Nov 17 10:32:06 UTC 2015


Hello to all!


I have the problem to change the context after login into a Cisco FWSM.

This is my clogin-command:



rancid at host:$  /usr/lib/rancid/bin/clogin -c 'terminal pager 0; changeto 
context system;sh running-config;exit' asa-address


spawn ssh -c 3des -x -l cisco_login asa-address

login at asa-address's password:

Type help or '?' for a list of available commands.

asa-address/admin> enable



asa-address/admin# terminal length 0


ERROR: % Invalid input detected at '^' marker.

asa-address/admin# terminal width 132


ERROR: % Invalid input detected at '^' marker.

asa-address/admin#  terminal pager 0

asa-address/admin#  changeto context system


Error: TIMEOUT reached

rancid at host:$



The timeout appears at nearly 45 seconds.


I tried to find out something with the -d option, but it looks ok.

I could post, if useful, the output also.

Other commands are functional, only the context-change has problems.


I ran this on a ASA 5585, and it works fine there! 

Also for our Switches (without context-change ;-)).

What could be the problem here? 


Thanks for help or new ideas!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20151117/3208e896/attachment.html>

More information about the Rancid-discuss mailing list