[rancid] Rancid with Dell 6248 errors

David Ahrens david.ahrens at citrix.com
Thu Oct 8 19:16:29 UTC 2015


I'm testing Rancid 3.2 with a Dell Powerconnect 6248.  The Dell is running version of the firmware.

When I run:
   /usr/local/rancid/bin/clogin -f .cloginrc rancid-test

I'm able to login and get a prompt  "rancid-test>".  If I hit return, I immediately get another command prompt.

When I run "/usr/local/bin/rancid-run"  The log file shows
             Error: TIMEOUT reached
             Missed cmd(s): all commands
             End of run not found

When I run
     /usr/local/rancid/bin/dllogin -f .cloginrc rancid-test
    /usr/local/rancid/bin/hlogin -f .cloginrc rancid-test

I get a prompt  "rancid-test>"    but if I hit return at the prompt,  there's no response and eventually the connection is closed with  "Error: TIMEOUT reached".

For my router.db file,  I've tried both

For .cloginrc file I have:
       add method {ssh}
       add autoenable rancid-test 1
       add timeout rancid-test {30}
       add cyphertype rancid-test {aes256-crtr}
       add user rancid-test {ranciduser}
       add password {##########}


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20151008/7533aa88/attachment.html>

More information about the Rancid-discuss mailing list