[rancid] Cisco IOS-XR Help - End of run not found

Asad axhasan5 at gmail.com
Mon Jun 13 00:59:55 UTC 2016

Hi All,

We are trying to add a few ASR9000 IOS-XR devices to Rancid 3.4.1. My issue 
seems similar 
to http://www.shrubbery.net/pipermail/rancid-discuss/2014-May/007597.html, I 
have un-commented NOPIPE=YES; export NOPIPE in rancid.conf and I have also 
tried to uncomment some of the show commands but it is still not working. 
To isolate any IOS-XR configuration issues I deployed a XRv with very basic 
configuration and I get same "end of run not found" error message.

Any help would be appreciated.

rancid at jp-script/opt/rancid#rancid -d -t cisco-xr lab-xrv-01
loadtype: device type cisco-xr
loadtype: found device type cisco-xr in /opt/rancid/etc/rancid.types.base
executing clogin -t 90 -c"terminal exec prompt no-timestamp;admin show 
version;admin show install summary;admin show license udi;admin show 
license;admin show variables boot;admin show hw-module fpd location 
all;show redundancy;show install active;admin show diag;admin show 
inventory raw;show debug;show rpl maximum;admin show running;show 
running-config" lab-xrv-01
PROMPT MATCH: RP/0/0/CPU0:lab-xrv-01#
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#terminal exec prompt no-timestamp
    In RunCommand: RP/0/0/CPU0:lab-xrv-01#terminal exec prompt no-timestamp
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#admin show version
    In ShowVersion: RP/0/0/CPU0:lab-xrv-01#admin show version
TYPE = XRv Series
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#admin show install summary
    In ShowInstallSummary: RP/0/0/CPU0:lab-xrv-01#admin show install summary
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#admin show license udi
    In ShowLicense: RP/0/0/CPU0:lab-xrv-01#admin show license udi
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#admin show license
    In ShowLicense: RP/0/0/CPU0:lab-xrv-01#admin show license
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#admin show variables boot
    In ShowBootVar: RP/0/0/CPU0:lab-xrv-01#admin show variables boot
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#admin show hw-module fpd location all
    In ShowRunning: RP/0/0/CPU0:lab-xrv-01#admin show hw-module fpd 
location all
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#show redundancy
    In ShowRedundancy: RP/0/0/CPU0:lab-xrv-01#show redundancy
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#show install active
    In ShowInstallActive: RP/0/0/CPU0:lab-xrv-01#show install active
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#admin show diag
    In ShowDiag: RP/0/0/CPU0:lab-xrv-01#admin show diag
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#admin show inventory raw
    In ShowInventory: RP/0/0/CPU0:lab-xrv-01#admin show inventory raw
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#show debug
    In ShowDebug: RP/0/0/CPU0:lab-xrv-01#show debug
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#show rpl maximum
    In ShowRPL: RP/0/0/CPU0:lab-xrv-01#show rpl maximum
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#admin show running
    In ShowRunning: RP/0/0/CPU0:lab-xrv-01#admin show running
HIT COMMAND:RP/0/0/CPU0:lab-xrv-01#show running-config
    In WriteTerm: RP/0/0/CPU0:lab-xrv-01#show running-config
lab-xrv-01: End of run not found
lab-xrv-01: End of run not found

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20160612/bd631c3f/attachment.html>

More information about the Rancid-discuss mailing list