[rancid] end of run not found

Wayne Eisenberg Wayne.Eisenberg at CarolinasIT.com
Fri Dec 14 16:15:41 UTC 2018

> > > Thu, Dec 13, 2018 at 07:55:29AM +0000, Wayne Eisenberg:
> > > > Regarding some PowerConnect N2000/3000/4000 series switches, I am
> > > getting "End of run not found" errors. If I use the smc type that is
> > > recommended in the rancid.types.base file, I have the added pleasure
> > > of getting "missed cmd(s): show version, dir, show vlan". Trying
> > > cisco as a type doesn't change the 'end of run' error, although I don't miss
> any commands.
> > > Trying my powerconnect type that I made earlier also results in 'end
> > > of run not found'.
> > > >
> > > > Running 'clogin -c"dir,show version,show running-config" switchname'
> > > works perfectly and returns to the command prompt.
> > > >
> > > > How do I troubleshoot 'end of run not found'?
> > > >
> > >
> > > it means that it did not find the end of the config.  look at the
> > > raw output and srancid -dl <hostname> for missed command matches.  I
> > > suspect that it srancid is not recognizing the prompt due to mangled
> > > input or unexpected characters in the prompt.
> >
> > How does one look at raw output?
> >
> >
> export NOPIPE YES ; srancid -dl <hostname> leaves hostname.raw

I'm not seeing the problem.

I ran:
export NOPIPE YES; rancid -t powerconnect -dl tco-core

powerconnect;script;rancid -t powerconnect
powerconnect;command;dell::GetSystem;show system
powerconnect;command;dell::GetConf;show running-config

(I remarked out the sub GetFile from dell.pm for testing only)

I got:
loadtype: device type powerconnect
loadtype: found device type powerconnect in /usr/local/rancid3/etc/rancid.types.conf
executing clogin -t 90 -c"show system;show running-config" tco-core
    In GetSystem: TCO-CORE#show system
HIT COMMAND:TCO-CORE#show running-config
    In GetConf: TCO-CORE#show running-config
Done clogin:
tco-core: End of run not found
tco-core: clean_run is false

And the .new file has a full copy of both 'show system' and 'show running-config'. No obvious mistakes.

Interestingly, if I put the GetFile sub back in and add it to the rancid.types.conf file, I get the same error and the .new file is the same - no directory listing. Weird.

Any other type of debugging that can be done?

More information about the Rancid-discuss mailing list