Nortel/bay routers and rancid

Mark Cooper mcooper at
Fri Jun 6 20:42:02 UTC 2003

The "$" prompt ? The bay's I've come across usually have a prompt of ">" 
which is probably the cause of your problem.

Try the following patch..

--- blogin.ORIG Fri Jun  6 21:12:57 2003
+++ blogin      Fri Jun  6 21:13:22 2003
@@ -483,7 +483,7 @@
             set prompt "#"
         } else {
             set autoenable 0
-           set prompt ">"
+           set prompt "$"

stefmit wrote:
> Here is what I have:
> .cloginrc:
> add password router password (tried also {password}
> add user router user (tried alternatively with the above, {user})
> add userprompt {Login:} 
> # the above is the only one getting me to the $ prompt, all other options
> # (e.g. {"Login:"}) leaving me at the Login: prompt!
> add autoenable router 1
> add userpwassword password 
> # lqast two lines tried without, with one at a time, with both, etc.
> With all five lines above, in the form I have them now, get me as far as the $ 
> prompt, which is one step before the bcc.
> When running the suggested:
> blogin -c "help" router
> I still stop at the $ prompt - no "help" and no logout.
> Any ideas of what could be wrong at this level?
> Thx,
> Stefan
> On Friday 06 June 2003 07:03 am, Mark Cooper wrote:
>>I did the original port to the Nortel/Bay platform, and brancid will run
>>bcc to get the configs. blogin does *not* do a bcc unless told to by
>>brancid or a 'blogin -c etc etc'
>>Can you confirm that blogin can successfully login and run commands? You
>>should be able to do something like:-
>>	blogin -c "help" <device>
>>and it should login to the device, run the help command, and then exit
>>without any errors. If it doesn't do this, brancid will not work either :)
>>I don't have access to any Nortel/Bay devices anymore so i'm a bit
>>limited in the support I can provide.
>>stefmit wrote:
>>>Thank you for your answer.
>>>To clarify a little bit: bcc is [a sort of] enable. After one gets the
>>>"regular" prompt, certain things can be carried out from there on, but
>>>this level of CLI is very limited, so additional steps have to be pursued
>>>for full access to configuration, i.e. moving into bcc. Here is how it
>>>usually works:
>>>telnet <bay-router>
>>>Login: <username>
>>>Password: <passwd>
>>><bay>$ bcc <CR>
>>>bcc> configure
>>>bcc# --> this is (in my opinion) the equivalent of Cisco's enable ... but
>>>I may be wrong. I was hoping someone has a Bay/Nortel router (really,
>>>really nobody out there?!?), and can confirm my supposition in regards to
>>>how far blogin or do-diff should get into.
>>>I guess the only alternative I have is to look into rancid's code, to see
>>>if the "bcc" assumption is correct, or what else I can do.
>>>Thx again,
>>>On Thursday 05 June 2003 10:38 pm, you wrote:
>>>>Thu, Jun 05, 2003 at 03:48:53PM -0500, stefmit:
>>>>>Has anybody been able to use rancid with Nortel routers? I have a BCN
>>>>>and I have tweaked the configs in all possible ways, but blogin won't
>>>>>go beyond the login (first level) ... i.e. never kicking in bcc. And -
>>>>>besides that - when doing blogin, vs. a regular telnet, I cannot log
>>>>>out - I have to CTRL/C the process.
>>>>i do not have one myself and i dont know what "bcc" is.  but, if you get
>>>>logged-in, followed by a prompt and then can not do anything, i would
>>>>suspect that your .cloginrc is misconfigured if the bcn has a concept
>>>>of "enable" (or entering privledged mode).
>>>>see the autoenable .cloginrc knob.


Mark Cooper - Network Management with Attitude - Open Source PVR Hardware Database

More information about the Rancid-discuss mailing list