[rancid] Re: clogin timing out after login

Michael Stefaniuc mstefani at redhat.com
Tue Aug 22 16:06:01 UTC 2006

Justin Sherrill wrote:
> I've got rancid set up on two different machines - One is RedHat
> Enterprise Linux 4, and the other is DragonFlyBSD 1.4.  These are new
> installs.  Both exhibit the same behavior.
> Using clogin to connect to a Cisco 7206 gets to a user prompt and then
> times out.
> # ./bin/clogin -c 'sh vers' ar01 
> User Access Verification
> Username: myusername
> Password: 
> ar01.lab01#
> Error: TIMEOUT reached
Looks like you go directly into enable mode without having to type in
enable and the enable password. If you want to keep that on the device
then you need to set in .cloginrc
add autoenable ar01 1


> Trying the same thing on a PIX 515 will time out as soon as it hits the 
> <--- More ---> prompt.  
> I've tried with the same result on multiple 7206/515 devices.  I can log
> in by hand normally.  I thought this was the linux/expect blocking
> problem, but patching for it hasn't fixed the issue.  Plus, it shouldn't
> be an issue on the BSD system.
> I'm getting a switch set up on the local network to make sure it isn't
> something strange between me and the test systems causing the problem.
> In the meantime, has anyone seen this and knows the (network-based?)
> issue that causes it?

Michael Stefaniuc               Tel.: +49-711-96437-199
Sr. Network Engineer            Fax.: +49-711-96437-111
Red Hat GmbH                    Email: mstefani at redhat.com
Hauptstaetterstr. 58            http://www.redhat.de/
D-70178 Stuttgart

More information about the Rancid-discuss mailing list