[rancid] clogin timing out after login

Justin Sherrill jsherrill at currentcomm.net
Tue Aug 22 14:51:27 UTC 2006

I've got rancid set up on two different machines - One is RedHat
Enterprise Linux 4, and the other is DragonFlyBSD 1.4.  These are new
installs.  Both exhibit the same behavior.

Using clogin to connect to a Cisco 7206 gets to a user prompt and then
times out.

# ./bin/clogin -c 'sh vers' ar01 
User Access Verification

Username: myusername


Error: TIMEOUT reached

Trying the same thing on a PIX 515 will time out as soon as it hits the 
<--- More ---> prompt.  

I've tried with the same result on multiple 7206/515 devices.  I can log
in by hand normally.  I thought this was the linux/expect blocking
problem, but patching for it hasn't fixed the issue.  Plus, it shouldn't
be an issue on the BSD system.

I'm getting a switch set up on the local network to make sure it isn't
something strange between me and the test systems causing the problem.
In the meantime, has anyone seen this and knows the (network-based?)
issue that causes it?

Justin C. Sherrill - CURRENT Communications 
100 Town Centre Drive, Suite G
Rochester, New York 14623
P: 585.486.0549 F: 585.486.0030

The information in this email may be confidential and/or privileged. This email is intended to be reviewed by only the individual or organization named above. If you are not the intended recipient or an authorized representative of the intended recipient, you are hereby notified that any review, dissemination or copying of this email and its attachments, if any, or the information contained herein is prohibited. If you have received this email in error, please immediately notify the sender by return email and delete this message from your system. 

More information about the Rancid-discuss mailing list