[rancid] Re: CVS problem

Todd Heide Todd at equivoice.com
Mon Aug 25 20:13:13 UTC 2008

That did it. Took me a while to remember "where" to run the cvs update,
and this isn't the first time I had to do it too, but if you don't do it
all the time, you forget. The files are updating finally, Thanks for
your help. 



From: Mike Ashcraft [mailto:mashcraft at omniture.com] 
Sent: Friday, August 22, 2008 5:23 PM
To: Todd Heide; rancid-discuss at shrubbery.net
Subject: RE: [rancid] CVS problem


This is caused by the files in the config directories that were created
by rancid-run not being originally checked out from the local instance
of CVS.


run 'cvs update' as the rancid user in the config directory for every
group and then run bin/rancid-run  again to get the current
configurations from the devices.  


If that doesn't work, it is hard to guess what other things may be
wrong/not working so it would be easiest to roll back to a clean install
and then copy your .cloginrc and router.db files back in.  The main
purpose of this would be to re-install and properly configure your CVS


From: rancid-discuss-bounces at shrubbery.net
[mailto:rancid-discuss-bounces at shrubbery.net] On Behalf Of Todd Heide
Sent: Friday, August 22, 2008 1:45 PM
To: rancid-discuss at shrubbery.net
Subject: [rancid] CVS problem


I have a server in production now that did at one time run Rancid, but
was put aside while other servers were worked on. Now I have it in
production, our main server that ran Rancid is dead, drive failure, and
the CVS configs are gone, but the rest of the files are intact. I moved
the .cloginrc file to the new server, which did run Rancid 13 months ago
on a test basis, and has a list of configs. I ran bin/rancid-run, got a
few timeouts, but those are mainly due to firewalls that I have to allow
access to from this server.


Problem I have encountered is, Rancid is working, but not updating the
configs in CVS. Tail of the group files is


cvs diff: Diffing .

cvs diff: Diffing configs

cvs commit: Examining .

cvs commit: Examining configs

ls: x.x.x.50: No such file or directory


I got this with both .cloginrc files. Where can I locate the file to
edit this out, or what the heck is is it and where the heck do I fix it?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20080825/5230fa69/attachment.html 

More information about the Rancid-discuss mailing list