[rancid] Re: HELP!

Mike Ashcraft mashcraft at omniture.com
Fri Jan 18 22:29:53 UTC 2008

>From your previous post, it looks like you do not have autoenable set
correctly in your .cloginrc file.  That would cause clogin to hang
trying to complete the login process, even though it had already
succeeded, and matches the screenshot you included.
If that doesn't fix it, search the archives of this mailing list for
details needed to verify you have the right version of expect.  Some
versions don't work properly.
Once that is done, if you are still having problems.  Provide full
details in your request to this list so that better help can be
Good luck,


From: rancid-discuss-bounces at shrubbery.net
[mailto:rancid-discuss-bounces at shrubbery.net] On Behalf Of Joshua
Sent: Friday, January 18, 2008 12:45 PM
To: rancid-discuss at shrubbery.net
Subject: [rancid] HELP!

Can anyone please help me.  I have been messaging the list now for a few
days looking for help.  I had a previous install of rancid on 3.2.1 that
worked perfectly, but now that I have rebuilt the server, I am getting
timeouts on the connections to the different devices.  I can logon as
the rancid user as before, but when I attempt to run clogin, it times
out!  I cannot imagine what could be causing this.  I have verified the
configs (based on the sysadmin install which I used before), and the


Please, any help is greatly appreciated!


Josh Sidwell, CISSP

Perimeter Systems Inc.

720-259-5374 (office)

303-668-3291 (cell)


No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.19.6/1231 - Release Date:
1/18/2008 11:55 AM 


From: rancid-discuss-bounces at shrubbery.net
[mailto:rancid-discuss-bounces at shrubbery.net] On Behalf Of Joshua
Sent: Thursday, January 17, 2008 1:32 PM
To: rancid-discuss at shrubbery.net
Subject: [rancid] all connections through clogin are timing out...

Ok, has anyone seen this before?  I can manually telnet into each of
these routers and use the userid that is setup for rancid and it all
works.  When I do a clogin to the same router, it logs in correctly,
then if I type any command it times out.  This happens on all of my
routers.  This is a rebuild of an older rancid server (v 2.3.1   we just
updated linux os version) that worked for these routers before.  I am
using FC8 and rancid 2.3.1 (unpatched).


Please, any and all help appreciated!






[rancid at rancid ~]$ bin/clogin 65.47.xxx.xxx


spawn telnet 65.47.xxx.xxx

Trying 65.47.xxx.xxx...

Connected to 65.47.xxx.xxx.

Escape character is '^]'.



User Access Verification


Username: rancid


[name removed]#sh run


Error: TIMEOUT reached

[rancid at rancid ~]$ sh run

sh: run: No such file or directory

[rancid at rancid ~]$

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20080118/3f0620b6/attachment.html 

More information about the Rancid-discuss mailing list