[rancid] Rancid seems to timeout on a certain device

Bryan registration at myplaceinspace.com
Mon May 23 18:38:54 UTC 2011

I am having an issue with Cisco IOS XR Software, Version 3.9.0 devices.  I have upgraded to rancid 2.3.6 and tried most everything else I know.  If I run in debug I can see that it does successfully login and start copying the config but quits mid stride with “Connection closed by foreign host.”  When it quits it does not do it after any sequence such as \n it can be right in the middle of a config line when it happens.  It can happen on different lines at times so this to me points to some kind of timeout.  If I manually run the same line it works fine and the config is downloaded in full to myhost.new.

clogin -t 90 -c "terminal exec prompt no-timestamp;show running-config" myhost</dev/null

I am open to any suggestions at this point.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20110523/c63a4c4c/attachment.html>

More information about the Rancid-discuss mailing list