[rancid] missed cmd(s): show full-configuration, get system status

Gareth Hopkins gabbawp at gmail.com
Thu May 31 08:30:13 UTC 2012


If you run fnlogin instead of clogin, you'll see it complains about an ssh port not being specified. I ran into exactly the same problem and mailed the list a couple of weeks ago but heard nothing back unfortunately. 

A quick work around is to add the following to your cloginrc file 

add method device_name     {ssh:22} 

I hope someone can take a look at this though.



On 30 May 2012, at 7:06 PM, Gerhard Mourani wrote:

> Helo list,
> After an update to Rancid version 2.3.8, the method used to login into FortiGate device no longer work and report the following error in the log file.
> Getting missed routers: round 4.
> fnlogin error: Error: Couldn't login:
> missed cmd(s): show full-configuration,get system status
> 0: found end
> End of run not found
> With previous version of Rancid, everything worked correctly. According to the above error I’ve run the following commands to verify if the missed cmd is true or not.
> /usr/bin/clogin -f /usr/share/rancid/.cloginrc
> The above works and I can manually run the ‘show full-configuration’ or ‘get system status’ command without problem!
> Therefore no idea about why this error occur now and from which part it’s really coming from!
> Gerhard,
> _______________________________________________
> Rancid-discuss mailing list
> Rancid-discuss at shrubbery.net
> http://www.shrubbery.net/mailman/listinfo.cgi/rancid-discuss

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20120531/f45c80f0/attachment.html>

More information about the Rancid-discuss mailing list