[rancid] SSH process hangs using cron with Aruba devices

Elle Plato techgrrl at gmail.com
Thu Feb 7 22:13:30 UTC 2013

> This works fine if I do it manually while SSH’ed into the Rancid server
> but if I run it through cron the ssh instances hang.
I don't run rancid, but I have some homegrown stuff I maintain that works 
in a similar fashion.
In general I look for differences in the execution environment.  
 - Dump the environment to look for changes in the path, etc.
 - If you are running as a different user, look for permissions issues.
 - maybe you cannot find your .cloginrc or some executable you are shelling 
out to.
 - Non-interactive shells behave differently than interactive shells in 
terms of sourcing dotfiles and more.
   You can force them to be treated as interactive, but if you have 
something expecting something on STDIN,
    you are going to be waiting for a long time.  

Have you tried enabled debugging using debug and exp_internal?  It can be 
real handy when expect is waiting on a pattern match, and you need to see 
exactly what it is waiting on.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20130207/ee1e6ff1/attachment.html>

More information about the Rancid-discuss mailing list