[rancid] rancid -t cisco host works but rancid host does not.

Gavin Jones gavinj84 at gmail.com
Mon May 5 06:22:53 UTC 2014

Andrei Sabau <fanachos <at> gmail.com> writes:

> Hello. I've recently installed Rancid on a Centos 6. I have worked with it 
before a bit but never encountered this issue.
> I have hosts assigned in the hosts file. I have the host added in 
> The clogin command works. The clogin -c command works.
> The log from run-rancid shows almost empty. I tried running the comands 
separately but 'rancid host' gives me a:loadtype(): device_type is empty
> Couldn't load device type spec for 
> but 'rancid -t cisco host' works. I'm thinking this has to do with rancid 
and the group's router.db.
> my group is in rancid.conf (LIST_OF_GROUPS="networking") but is the 
networking/router.db even read?
> Any ideas are helpful, thanks.
> _______________________________________________
> Rancid-discuss mailing list
> Rancid-discuss <at> shrubbery.net
> http://www.shrubbery.net/mailman/listinfo/rancid-discuss

I too am having this exact problem, surely there is a fix??


More information about the Rancid-discuss mailing list