[rancid] Rancid submits random characters after logon - causes config read failure

Neil Arnold n.arnold at gmail.com
Fri Sep 12 13:36:33 UTC 2014

Hi Jethro, I've tried the hlogon too. No luck I'm afraid.

John, this sounds like it could be the solution as the characters do look
like terminal output. Can you explain how I would go about clearing the
TERM environment and if this works, I'm assuming I would have to make a
seperate cron job running clogin with these new parameters just for these
problem switches?

Thanks again for you help with this.

On 12 September 2014 13:03, Jon Lewis <jlewis at lewis.org> wrote:

> On Fri, 12 Sep 2014, Neil Arnold wrote:
>  Hi,
>> I've got an issue with 3 HP Procurve switches. All are running a recent
>> firmware version. The problem is that no config is being pulled from 3 HP
>> switches. in my network, the others give up their config just fine. I've
>> discovered the reason but I'm unsure of how to fix it.
>> The issue is caused because rancid is issuing the following command to the
>> switch after it logs on: ^[[46;148R
>> I can see this by running /bin/clogin and seeing that I get
>> dropped to the following:
>> HP_SWITCH_1# ^[[46;148R
>> So Rancid is issuing the manager username and password and then issuing
>> ^[[46;148R which the switch doesn't understand, Rancid, having not
>> received
> I have similar problems with clogin and arista gear.  In this case, it's
> solved by clearing the TERM environment variable before running clogin.
> ----------------------------------------------------------------------
>  Jon Lewis, MCP :)           |  I route
>                              |  therefore you are
> _________ http://www.lewis.org/~jlewis/pgp for PGP public key_________
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20140912/4cee509c/attachment.html>

More information about the Rancid-discuss mailing list