[rancid] vyatta/vyos

robert.4.hughes at bt.com robert.4.hughes at bt.com
Wed Apr 1 13:26:25 UTC 2015

Yes, although rather than router01 it is an actual ip address. The same works for quagga nodes ok, those are using a device type of cisco.

xx.xx.xx.xx;vyos;up;node provisioned by opennms nodeid;14

-----Original Message-----
From: Antonio Querubin [mailto:tony at lavanauts.org] 
Sent: 01 April 2015 14:20
To: Hughes,R,Robert,VIE C
Cc: adam at ballinatta.com; rancid-discuss at shrubbery.net
Subject: RE: [rancid] vyatta/vyos

On Wed, 1 Apr 2015, robert.4.hughes at bt.com wrote:

> I have installed the new modules, so I guess it was just ignoring 
> vrancid anyway. I have now deleted vrancid to make sure.
> I still get the error in the log file router01: vlogin error: Error: 
> TIMEOUT reached

> This is the vyos entry in rancid.types.conf
> vyos;script;rancid -t vyos
> vyos;login;vlogin
> vyos;module;vyos
> vyos;inloop;vyos::inloop
> vyos;command;vyos::ShowConfiguration;show configuration commands
> This is the output when I run:   rancid -t vyos -d router01
> loadtype: device type vyos
> loadtype: found device type vyos in /opt/rancid/etc/rancid.types.conf 
> executing vlogin -t 120 -c"show configuration commands" router01 HIT 
> COMMAND:vyos at router01:~$ show configuration commands
>        In ShowConfiguration: vyos at router01:~$ show configuration 
> commands

So you shouldn't be getting that TIMEOUT error any more.  Is your router.db entry for router01 referencing 'vyos' instead of 'vrancid'?


Antonio Querubin
e-mail:  tony at lavanauts.org
xmpp:  antonioquerubin at gmail.com

More information about the Rancid-discuss mailing list