[rancid] new rancid install not working

Jeffrey d'Ambly jeffrey.dambly at jasper.com
Fri Apr 17 22:41:54 UTC 2015

I cannot for the life of me figure out what I’m doing wrong here.

When I run /usr/bin/rancid-run it seems like nothing happens. When I run rancid manually I get the following

qa-scl009-005:/var/rancid# /usr/bin/rancid -d -t cisco sjc-vpe1

loadtype: device type cisco

loadtype: found device type cisco in /etc/rancid/rancid.types.base

executing clogin -t 90 -c"show version;show redundancy;show idprom backplane;show install active;show env all;show rsp chassis-info;show gsr chassis;show diag chassis-info;show boot;show bootvar;show variables boot;show flash;dir /all nvram:;dir /all bootflash:;dir /all slot0:;dir /all disk0:;dir /all slot1:;dir /all disk1:;dir /all slot2:;dir /all disk2:;dir /all harddisk:;dir /all harddiska:;dir /all harddiskb:;dir /all sup-bootdisk:;dir /all sup-bootflash:;dir /all sup-microcode:;dir /all slavenvram:;dir /all slavebootflash:;dir /all slaveslot0:;dir /all slavedisk0:;dir /all slaveslot1:;dir /all slavedisk1:;dir /all slaveslot2:;dir /all slavedisk2:;dir /all slavesup-bootflash:;dir /all sec-nvram:;dir /all sec-bootflash:;dir /all sec-slot0:;dir /all sec-disk0:;dir /all sec-slot1:;dir /all sec-disk1:;dir /all sec-slot2:;dir /all sec-disk2:;show controllers;show controllers cbus;show diagbus;show diag;show capture;show module;show spe version;show c7200;show inventory raw;show vtp status;show vlan;show vlan-switch;show switch detail;show sdm prefer;show system mtu;show debug;show shun;more system:running-config;show running-config view full;show running-config;write term" sjc-vpe1

sh: clogin: command not found

sjc-vpe1: missed cmd(s): all commands

sjc-vpe1: End of run not found

sjc-vpe1: End of run not found

But if I can clogin manually it works

qa-scl009-005:/var/log/rancid# /usr/libexec/rancid/clogin -t 90 -c"show version" sjc-vpe1


spawn ssh -c 3des -x -l confbackup sjc-vpe1



sjc-vpe1#terminal length 0

sjc-vpe1#terminal width 132

sjc-vpe1#show version

Cisco IOS Software, C3900e Software (C3900e-UNIVERSALK9-M), Version 15.2(4)M7, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2014 by Cisco Systems, Inc.

Compiled Thu 25-Sep-14 10:09 by prod_rel_team

ROM: System Bootstrap, Version 15.1(1r)T5, RELEASE SOFTWARE (fc1)

I have no idea what the hell I am doing wrong here, if someone could point me in the right direction here that would be awesome.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20150417/67a76e1c/attachment.html>

More information about the Rancid-discuss mailing list