[rancid] blank log files on initial install

Scott Granados scott.granados at gmail.com
Thu May 7 16:36:55 UTC 2015

This was the exact problem.  I switched to using ; delimiters and it worked great.

Thank you.  Your help was very much appreciated.

On May 6, 2015, at 9:08 PM, Kenneth <lind108 at hotmail.com> wrote:

> Check your router.db file and ensure you're using the correct delimiter. I had the same problem when I first upgraded to 3.1 and it took me far too long to find that you need to use a semicolon instead of a colon (a little RTFM and some hair pulling helped) and I experienced the same problem you describe.
> Example router.db entry for 3.1+ (to allow for IPv6 addressing):
> Hostname;cisco;up
> On May 6, 2015 20:57, Scott Granados <scott.granados at gmail.com> wrote:
> Hi, this may be a very n00by question but googling hasn’t helped so I thought I’d ask here.  I just installed a fresh copy of rancid-3.2.  Admittedly my previous attempt has been using yum or apt-get to install rancid 2.3.6 but this time I downloaded the source and compiled.  There were no errors during compilation.
>         When I run rancid-run the process exits very quickly and the generated log files for each group show a start and end with no text in-between.  However, if I run the clog in command with a router name it logs in fine and drops me in to the network element.  What should I check to diagnose the lack of configs being pulled and the totally empty logs other than the words start and end.  Any pointers would be most appreciated.
> Thank you
> Scott
> _______________________________________________
> Rancid-discuss mailing list
> Rancid-discuss at shrubbery.net
> http://www.shrubbery.net/mailman/listinfo/rancid-discuss

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20150507/c6b693a6/attachment.html>

More information about the Rancid-discuss mailing list