[rancid] “Error : TIMEOUT Reached” Rancid

Alan McKinnon alan.mckinnon at gmail.com
Tue Nov 10 21:10:00 UTC 2015

On 10/11/2015 21:40, pradeep s wrote:
> Hi,
> I know this error have been in archive list but I don’t see any response
> for that. Am also getting the same error. When I do “clogin ip” , I can
> see its gets logged into the remote system but after a while it gets
> exit stating “Error : TIMEOUT Reached”
> I have set timeout value to be 90 but no luck. My .cloginrc config is  ,
> add method <ip> ssh
> add password <ip> N0ps2012
> add user  <ip> vyatta
> add autoenable  <ip> 1
> I have tried changing autoenable to noenable but still same. Could
> anyone guide me from here it would be great.

There's no standard answer for that situation, all you can tell at this
point is that something went wrong, and the list of possibilities is the
full list of how an ssh login can fail.

Can you login with just ssh as normal using those credentials? Is the
sequence normal? ssh host key errors perhaps? Are your prompts OK and
the expected form (> for user, # for enabled), and are there no > and #
characters in the banner?

Use clogin and watch closely what is happening on the screen - something
is waiting for something to happen and the clue to what that is might be
on the screen.

Failing that, run clogin with -d and inspect the output closely.
Warning: that option can be very verbose.

There's not much more anyone can assist you with given the info
provided, there are just too many ways for a login to fail, and they all
give similar error messages
Alan McKinnon
alan.mckinnon at gmail.com

More information about the Rancid-discuss mailing list