[rancid] Rancid failing after OS upgrade

Shawn Laemmrich shawn at rmrf.us
Sat Feb 20 15:15:29 UTC 2016

I've had rancid 3.2 running (on ubuntu) for weeks now without issues.
Yesterday, I upgraded the OS (ubuntu do-release-upgrade) and now rancid is
giving me cvs errors when I run rancid-run

property 'svn:ignore' set on '.'
property 'svn:ignore' set on 'configs'
Updating '.':
At revision 3.
Sending        .
Sending        configs
Sending        router.db
Transmitting file data .
Committed revision 4.

svn: E125001: '/var/lib/rancid/bob/configs/.cvsignore' does not exist
Deleted .cvsignore

I usually use CVS instead of SVN but thought I'd give it a shot, since I
got similar errors with CVS.

When I run rancid-run, I get this error in the log file almost immediately
and it puts all my hosts in routers.down

So far I've tried

verifying clogin and all that stuff (works fine, I can use clogin to get
into anything)

removing my rancid config, and re-running rancid-cvs to create the required
directories (didn't help)

removing and purging rancid and cvs from the machine and re-installing
(verified it installed correctly)

running rancid by hand rancid -t cisco xxx.yyy.zzz.aaa for a device, which
works fine and creates a device.new file correctly.

So, it definitely seems to be a CVS thing, but for the life of me I can't
figure out what it's mad about or how to make it work again.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20160220/d83ddba8/attachment.html>

More information about the Rancid-discuss mailing list