[rancid] Alcatel Lucent switches

luca comes lucacomes at hotmail.it
Mon May 8 14:23:19 UTC 2017

Hi all,

this is my first message on the list so I apologize in advance for any mistake. I've got a working rancid 3.6.2 installation on a CentOS 7 platform who is working on Cisco/HP switches with no problems. Now I need to include in it also some Alcatel Lucent platforms, OS 6850 and OS 6450 but it seems they aren't supported yet. I'm not a programmer but I tried to adapt some existing script login/rancid to get all the information I need but I have two problems. First of all seems that the script cannot parse the exit command so always an "end of run not found" is showed even if all the commands work fine. The second issue is that if I run the script manually from the bin directory it works well and the .new file is written. But if I try to get it working via rancid-run nothing happen. I've obviously added the right types in rancid.types.conf as:

alcatel;script;alurancid -t alcatel

Aand populated router.db file, can someone help me? Attached the scripts used.

Thank in advance


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20170508/ac1c12cb/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: alulogin
Type: application/octet-stream
Size: 23472 bytes
Desc: alulogin
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20170508/ac1c12cb/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: alurancid
Type: application/octet-stream
Size: 14933 bytes
Desc: alurancid
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20170508/ac1c12cb/attachment-0001.obj>

More information about the Rancid-discuss mailing list