[rancid] Alcatel Lucent switches

heasley heas at shrubbery.net
Tue May 9 21:17:06 UTC 2017

Mon, May 08, 2017 at 02:23:19PM +0000, luca comes:
> Hi all,
> this is my first message on the list so I apologize in advance for any mistake. I've got a working rancid 3.6.2 installation on a CentOS 7 platform who is working on Cisco/HP switches with no problems. Now I need to include in it also some Alcatel Lucent platforms, OS 6850 and OS 6450 but it seems they aren't supported yet. I'm not a programmer but I tried to adapt some existing script login/rancid to get all the information I need but I have two problems. First of all seems that the script cannot parse the exit command so always an "end of run not found" is showed even if all the commands work fine. The second issue is that if I run the script manually from the bin directory it works well and the .new file is written. But if I try to get it working via rancid-run nothing happen. I've obviously added the right types in rancid.types.conf as:

if you can try
sros (nokia/alcatel/insert the other 50 names for it) support has been
added.  Needs a bit more work, but it is stable.

More information about the Rancid-discuss mailing list