[rancid] problems with PowerConnect switches

heasley heas at shrubbery.net
Fri Dec 7 20:05:48 UTC 2018

Fri, Dec 07, 2018 at 10:18:54AM +0000, Wayne Eisenberg:
> Hi,
> I have a PowerConnect 5448 that I am having trouble with. If I run the steps manually it's fine, but using rancid-run always fails.
> The router.db file is:
> pc5448;powerconnect;up
> The etc/rancid.types.conf section is:
> powerconnect;script;rancid -t powerconnect
> powerconnect;login;clogin
> powerconnect;module;dell
> powerconnect;inloop;dell::inloop
> powerconnect;command;dell::GetSystem;show system
> powerconnect;command;dell::GetConf;show running-config
> and all the info in .clogin is fine.
> If I manually run clogin for that switch, it has no problems. Then running 'show system' and 'show running-config' gives no problems.

meaning that
clogin -c 'show system;show running-config' hostname
completes w/o a timeout?  if so, that implies to me that either a pager is
involving itself in an unrecognized manner or there is other unrecognized
input preventing it from finding the prompt reliably, possibly due to TERM
settings (and poor defaults).  that could be tested, or it might debugging
to, run that clogin from cron to see how it acts w/o a terminal.

> If I run 'bin/rancid-run -r pc5448', the error messages are:
> Trying to get all of the configs.
> pc5448: missed cmd(s): all commands
> pc5448: End of run not found
> pc5448 dllogin error: Error: TIMEOUT reached
> I cannot figure out why rancid-run is trying to use dllogin when I have nothing that says to use it. Can someone help me sort this out?

its not, its just the hard-coded error msg of dell.pm.

More information about the Rancid-discuss mailing list