[rancid] problems with PowerConnect switches

Wayne Eisenberg Wayne.Eisenberg at CarolinasIT.com
Fri Dec 7 10:18:54 UTC 2018


I have a PowerConnect 5448 that I am having trouble with. If I run the steps manually it's fine, but using rancid-run always fails.

The router.db file is:

The etc/rancid.types.conf section is:

powerconnect;script;rancid -t powerconnect
powerconnect;command;dell::GetSystem;show system
powerconnect;command;dell::GetConf;show running-config

and all the info in .clogin is fine.

If I manually run clogin for that switch, it has no problems. Then running 'show system' and 'show running-config' gives no problems.

If I run 'bin/rancid-run -r pc5448', the error messages are:

Trying to get all of the configs.

pc5448: missed cmd(s): all commands
pc5448: End of run not found
pc5448 dllogin error: Error: TIMEOUT reached

I cannot figure out why rancid-run is trying to use dllogin when I have nothing that says to use it. Can someone help me sort this out?


More information about the Rancid-discuss mailing list