[rancid] Rancid not updating

on at LEFerguson.com on at LEFerguson.com
Wed Oct 17 14:27:37 UTC 2018

You have a bunch of issues, but I agree, the "up to date" is an issue.  I know almost nothing about CVS, it just plugged in and worked for me, so hopefully someone can work.

Many of the other errors are configuration and router change issues, e.g.

The "refused" implies that device does not (or no longer) allow telnet.  Whether it ever worked is another issue, but you need to get the login protocol (defined in .cloginrc) to match what the devices allow.

A distantly related issue is the "host key ... has changed".  This is usually from a router change/upgrade, where ssh (used by rancid to pull configs) has stashed a key, and it is warning you that you may be seeing a different device (e.g. a spoofing of some sort).   You can clear these individually (log in as rancid, and ssh to the device, and follow what it prompts -- you may need to remove it from the indicated file entirely, it tells you the line), or just delete the entire key file and let it rebuild, or (not a great idea if it's a general use machine for security reasons but OK if it's pure NMS) edit /etc/ssh/ssh_config and put in something like this:

StrictHostKeyChecking no


Doing that from memory, google for ssh key changes and you'll find lots of different approaches.

The timeouts may be simply missing devices.  The end of runs not found are usually devices not supported, or that have been entered with incorrect device types.

It MAY be that the "up to date" checks are because these commands are all failing, or you might have a CVS problem.  If it was me I'd fix some of these first (e.g. the SSH keys are easy to fix), and then run it again and see if anything changes.  In particular fix it for one listed in the up-to-date error (e.g. and see if the up-to-date goes away when it can process the device.

Hopefully someone more CVS knowledgeable can advise on what that actually means.


From: Larry Larsen [mailto:llarsen at longlines.biz]
Sent: Wednesday, October 17, 2018 9:49 AM
To: on at LEFerguson.com; rancid-discuss at shrubbery.net
Subject: RE: Rancid not updating


Thank you for your assistance.  Attached is the log.  I think the biggest error is Up-to-Date check failed and I have to correct the errors first.  I have tried a cvs update, but I get the error:

cvs update: No CVSROOT specified!  Please use the `-d' option
cvs [update aborted]: or set the CVSROOT environment variable.

Any other assistance would be appreciated.

Thank you!

Larry L.

From: on at LEFerguson.com<mailto:on at LEFerguson.com> <on at LEFerguson.com<mailto:on at LEFerguson.com>>
Sent: Tuesday, October 16, 2018 5:24 PM
To: Larry Larsen <llarsen at longlines.biz<mailto:llarsen at longlines.biz>>; rancid-discuss at shrubbery.net<mailto:rancid-discuss at shrubbery.net>
Subject: RE: Rancid not updating

Start by looking in the log file (usually in the rancid directory structure, try ~/var/rancid/logs (though I think depending on how installed it may be elsewhere).  Find the latest log, look at it, see what is happening.

If it's not there (i.e. no logs) rancid is probably not starting.  Restarting it depends on linux variant, but if a reboot is possible just reboot.

If the log is there and it gives an error, start with that as it should give a clue.  Post results if you need further help after seeing that.

There are also lots of debugging postings on the net (just try searching for rancid debug), indeed one technique is to follow the install instructions after the install where it describes how to test login, etc.


From: Rancid-discuss [mailto:rancid-discuss-bounces at shrubbery.net] On Behalf Of Larry Larsen
Sent: Tuesday, October 16, 2018 5:00 PM
To: rancid-discuss at shrubbery.net<mailto:rancid-discuss at shrubbery.net>
Subject: [rancid] Rancid not updating


I am new to the company, and my predecessor had setup Rancid to collect all our configs and do the comparisons.  He also used CVS to display the configs on a webpage.  I have no experience with Rancid nor CVS and I was wondering if I could get some assistance.   Here is my issue.  I am a Windows guy, and am learning Linux.

I made a small change on one of my routers to SNMP, and wanted to see if Rancid would pick it up.  The date on the file still shows 7 months ago, and not the change I made earlier today.  We make changes almost daily for VLANS, etc, and nothing is showing updated.

The schedule to download and send config difference emails is every hour.  I have seen multiple emails, but nothing with my change in it.  I also went into the Rancid directory structure in Linux and the date in there is also 7 months old.  Is there anything you can do to assist?

Thank you!

Larry L.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20181017/8dfcf2c5/attachment.html>

More information about the Rancid-discuss mailing list