Summary of Solaris 9 DDI/DKI Services
Introduction
This appendix discusses the interfaces provided by the Solaris 9 DDI/DKI. These descriptions should not be considered complete or definitive, nor do they provide a thorough guide to usage. The descriptions are intended to describe what the functions do in general terms. See man pages section 9F: DDI and DKI Kernel Functions for more detailed information. The categories are:
This appendix does not discuss STREAMS interfaces; to learn more about network drivers, see the STREAMS Programming Guide.
Module Functions
Table B-1 Module Functions
Function Name | Description |
---|---|
query a loadable module | |
mod_install | add a loadable module |
mod_remove | remove a loadable module |
Device Information Tree Node (dev_info_t) Functions
Table B-2 Device Information Tree Node (dev_info_t) Functions
Function Name | Description |
---|---|
return driver binding name | |
ddi_dev_is_sid | tell whether a device is self-identifying |
ddi_driver_major | return driver major device number |
ddi_driver_name | return normalized driver name |
ddi_node_name | return the devinfo node name |
ddi_get_devstate | check device state |
ddi_get_instance | get device instance number |
ddi_get_name | return driver binding name |
ddi_get_parent | find the parent of a device information structure |
ddi_root_node | get the root of the dev_info tree |
Device (dev_t) Functions
Table B-3 Device (dev_t) Functions
Function Name | Description |
---|---|
create a minor node for a device | |
ddi_getiminor | get kernel internal minor number from an external dev_t |
ddi_remove_minor_node | remove a minor mode for a device |
getmajor | get major device number |
getminor | get minor device number |
makedevice | make device number from major and minor numbers |