[rancid] Cisco WLC: Rancid 3.0 add other vendor devices???

Gavin Jones gavinj84 at gmail.com
Sun May 18 23:56:11 UTC 2014

Hi Josh,
            Heasley who is on this list recently solved this issue for me,
he gave me a patch to recompile back into the source. I will await him to
reply with the patch as he can explain it better.


On Sat, May 17, 2014 at 6:36 AM, Joshua Lebo <sclebo05 at gmail.com> wrote:

> Gavin,
> I'm having the exact same issues.  I'm also poking around at code, and I
> have noticed that Rancid::loadtype is a subrouting in lib/rancid/rancid.pmnot it's own module.
> For completeness, I'm showing my rancid.types.conf contents:
> ciscowlc;login;wlogin
> ciscowlc;script;ciscowlc5
> and my error:
> Trying to get all of the configs.
> Unknown option: t
> ciscowlc5 wlogin error: Error: no password for ciscowlc5 in
> /home/rancid/.cloginrc.
> ciscowlc5: missed cmd(s): show sysinfo,show udi,show run-config commands
> ciscowlc5: End of run not found
> I was able to resolve 'Unknown option: t' was resolved by catching the
> option, by editing line 30 and adding 't'.
> The above wlogin error should probably read <devicename> instead of
> <ciscowlc5>, leading me to believe that our scripts are not parsing
> something correctly.  Did the change in router.db from ':' to ';' in
> version 3.0 break the script?
> Interestingly, if I run ./ciscowlc5 <devicename> from within the bin
> directory, the complete config is pulled down and saved as a .new file.
> Password, etc is correctly configured.  So I know the scripts work, having
> trouble getting them to run via rancid-run in version 3.0.
> - Josh
> _______________________________________________
> Rancid-discuss mailing list
> Rancid-discuss at shrubbery.net
> http://www.shrubbery.net/mailman/listinfo/rancid-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.shrubbery.net/pipermail/rancid-discuss/attachments/20140519/cc8a43d8/attachment.html>

More information about the Rancid-discuss mailing list