|
System Administration Commands | dmi_cmd(1M) |
| dmi_cmd - DMI command line interface utility |
SYNOPSIS
| dmi_cmd -AL -c compId -g groupId [-dp] [-a attrId] [-m max-count] [-r req-mode] [-s hostname] |
| dmi_cmd -CD -c compId [-s hostname] |
| dmi_cmd -CI mif-file [-s hostname] |
| dmi_cmd -CL [-dp] [-c compId] [-m max-count] [-r req-mode] [-s hostname] |
| dmi_cmd -GD -c compId -g groupId [-s hostname] |
| dmi_cmd -GI schema-file -c compId [-s hostname] |
| dmi_cmd -GL -c compId -g groupId [-dp] [-m max-count] [-r req-mode] [-s hostname] |
| dmi_cmd -GM -c compId [-m max-count] [-s hostname] |
| dmi_cmd -ND -c compId -l language-string [-s hostname] |
| dmi_cmd -NI schema-file -c compId [-s hostname] |
| dmi_cmd -NL -c compId [-s hostname] |
| dmi_cmd -W config-file [-s hostname] |
|
The dmi_cmd utility provides the ability to:
- Obtain version information about the DMI Service Provider
- Set the configuration to describe the language required by the management application
- Obtain configuration information describing the current language in use for the session
- Install components into the database
- List components in a system to determine what is installed
- Delete an existing component from the database
- Install group schemas to an existing component in the database
- List class names for all groups in a component
- List the groups within a component
- Delete a group from a component
- Install a language schema for an existing component in the database
- List the set of language mappings installed for a specified component
- Delete a specific language mapping for a component
- List the properties for one or more attributes in a group
|
|
The following options are supported:
- -a attrId
- Specify an attribute by its ID (positive integer). The default
value is 0.
- -AL
- List the attributes for the specified component.
- -c compId
- Specify a component by its ID (positive integer). The default value is 0.
- -CD
- Delete the specified component.
- -CI mif-file
- Install the component described in the mif-file.
- -CL
- List component information.
- -d
- Display descriptions.
- -g groupId
- Specify a group by its ID (positive integer). The default value is 0.
- -GD
- Delete a group for the specified component.
- -GI schema-file
- Install the group schema specified in schema-file.
- -GL
- List the groups for the specified component.
- -GM
- List the class names for the specified component.
- -h
- Help. Print the command line usage.
- -l language-string
- Specify a language mapping.
- -m max-count
- Specify the maximum number of components to display.
- -ND
- Delete a language mapping for the specified component.
- -NI schema-file
- Install the language schema specified in schema-file.
- -NL
- List the language mappings for a specified component.
- -p
- Display the pragma string.
- -r req-mode
- Specify the request mode. The valid values are:
-
1
- DMI_UNIQUE - access the specified item (or table row).
-
2
- DMI_FIRST - access the first item.
-
3
- DMI_NEXT - access the next item.
The default request mode is 1 DMI_UNIQUE.
- -s hostname
- Specify the host machine on which dmispd is running. The default host is the local host.
- -V
- Version. Prints version information about the DMI Service Provider.
- -W config-file
- Set the configuration specified in config-file to dmispd.
- -X
- Retrieve configuration information describing the current language in use.
|
|
The following error values are returned:
-
0
- Successful completion.
-
-1
- An error occurred.
|
|
See attributes(5) for descriptions of the following
attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWsadmi |
|
| |