|
System Administration Commands | eeprom(1M) |
| eeprom - EEPROM display and load utility |
SYNOPSIS
SPARC
|
| /usr/platform/ platform-name /sbin/eeprom [-] [-f device] [ parameter [=value] ] |
|
IA
|
| /usr/platform/ platform-name /sbin/eeprom [-] [-f device] [-I] [mmu-modlist] [ parameter [ =value] ] |
|
|
eeprom displays or changes the values of parameters in the EEPROM. It processes parameters in the order given. When processing a parameter accompanied
by a value, eeprom makes the indicated alteration to the EEPROM; otherwise, it displays the parameter's value. When given no parameter specifiers, eeprom displays the values of
all EEPROM parameters. A `-' (hyphen) flag specifies that parameters and values are to be read from the standard input (one parameter or parameter=value per line).
Only the super-user may alter the EEPROM contents.
eeprom verifies the EEPROM checksums and complains if they are incorrect.
platform-name is the name of the platform implementation and can be found using the -i option of uname(1).
SPARC
|
SPARC based systems implement firmware password protection with eeprom, using the security-mode, security-password and security-#badlogins properties.
|
IA
|
EEPROM storage is simulated using a file residing in the platform-specific boot area. The /platform/platform-name/boot/solaris/bootenv.rc file simulates EEPROM storage.
Because IA based systems typically implement password protection in the system BIOS, there is no support for password protection in the eeprom program. While it is possible to set the security-mode, security-password and security-#badlogins properties on IA based systems, these properties have no special meaning or behavior on IA based systems.
|
|
|
- -f device
- Use device as the EEPROM device.
IA Only
|
- -I
- Initialize boot properties on an IA based system. Only init(1M) run-level initialization
scripts should use this option.
|
|
|
IA Only
|
-
acpi-user-options
- A configuration variable that controls the use of ACPI. A value of 0x0 attempts to use ACPI if it is available on the system.
A value of 0x2 disables the use of ACPI. Defaults to 0x0.
-
mmu-modlist
- A colon-separated list of candidate modules that implement memory management. If mmu-modlist is defined, it overrides the default list derived from the memory configuration on IA
based systems. Instead, the first module in the list that is found in /platform/platform-name/kernel/mmu is used.
|
|
|
Not all OpenBoot systems support all parameters. Defaults vary depending on the system and the PROM revision. See the output in the "Default Value" column of the printenv command, as entered at the ok (OpenBoot) prompt, to determine
the default for your system.
- auto-boot?
- If true, boots automatically after power-on or reset. Defaults to true.
- ansi-terminal?
- Configuration variable used to control the behavior of the terminal emulator. The value false makes the terminal emulator stop interpreting ANSI escape sequences; instead, echoes them to the
output device. Defaults to true.
- boot-command
- Command executed if auto-boot? is true. Defaults to boot.
- boot-device
- Device from which to boot. boot-device may contain 0 or more device specifiers separated by spaces. Each device specifier may be either a prom device alias or a prom device path. The boot prom will attempt to open each successive
device specifier in the list beginning with the first device specifier. The first device specifier that opens successfully will be used as the device to boot from. Defaults to disk net.
- boot-file
- File to boot (an empty string lets the secondary booter choose default). Defaults to empty string.
- boot-from
- Boot device and file (OpenBoot PROM version 1.x only). Defaults to vmunix.
- boot-from-diag
- Diagnostic boot device and file (OpenBoot PROM version 1.x only). Defaults to le()unix.
- comX-noprobe
- Where X is the number of the serial port, prevents device probe on serial port X.
- diag-device
- Diagnostic boot source device. Defaults to net.
- diag-file
- File from which to boot in diagnostic mode. Defaults to empty string.
- diag-level
- Diagnostics level. Values include off, min, max and menus. There may be additional platform-specific values. When set to off, POST is not called. If POST is called, the value is made available as an argument to, and is interpreted by POST. Defaults to platform-dependent.
- diag-switch?
- If true, run in diagnostic mode. Defaults to false on most desktop systems, true on most servers.
- error-reset-recovery
- Recover after an error reset trap. Defaults to platform-specific setting.
On platforms supporting this variable, it replaces the watchdog-reboot?, watchdog-sync?, redmode-reboot?, redmode-sync?, sir-sync?, and xir-sync? parameters.
The options are:
- none
- Print a message describing the reset trap and go to OpenBoot PROM's user interface, aka OK prompt.
- sync
- Invoke OpenBoot PROM's sync word after the reset trap. Some platforms may treat this as none after an externally initiated reset (XIR) trap.
- boot
- Reboot after the reset trap. Some platforms may treat this as none after an XIR trap.
- fcode-debug?
- If true, include name parameter for plug-in device FCodes. Defaults to false.
- hardware-revision
- System version information.
- input-device
- Input device used at power-on (usually keyboard, ttya, or ttyb). Defaults to keyboard.
- keyboard-click?
- If true, enable keyboard click. Defaults to false.
- keymap
- Keymap for custom keyboard.
- last-hardware-update
- System update information.
- load-base
- Default load address for client programs. Default value is 16384.
- local-mac-address?
- If true, network drivers use their own MAC address, not the system's. Defaults to false.
- mfg-mode
- Manufacturing mode argument for POST. Possible values include off or chamber. The value is passed as an argument to POST. Defaults to off.
- mfg-switch?
- If true, repeat system self-tests until interrupted with STOP-A. Defaults to false.
- nvramrc
- Contents of NVRAMRC. Defaults to empty.
- oem-banner
- Custom OEM banner (enabled by setting oem-banner? to true). Defaults to empty string.
- oem-banner?
- If true, use custom OEM banner. Defaults to false.
- oem-logo
- Byte array custom OEM logo (enabled by setting oem-logo? to true). Displayed in hexadecimal.
- oem-logo?
- If true, use custom OEM logo (else, use Sun logo). Defaults to false.
- output-device
- Output device used at power-on (usually screen, ttya, or ttyb). Defaults to screen.
- redmode-reboot?
- Specify true to reboot after a redmode reset trap. Defaults to true. (Sun Enterprise 10000 only.)
- redmode-sync?
- Specify true to invoke OpenBoot PROM's sync word after a redmode reset trap. Defaults to false. (Sun Enterprise 10000 only.)
- sbus-probe-list
- Designate which SBus slots are probed and in what order. Defaults to 0123.
- screen-#columns
- Number of on-screen columns (characters/line). Defaults to 80.
- screen-#rows
- Number of on-screen rows (lines). Defaults to 34.
- scsi-initiator-id
-
SCSI bus address of host adapter, range 0-7. Defaults to 7.
- sd-targets
- Map SCSI disk units (OpenBoot PROM version 1.x only). Defaults to 31204567, which means that unit 0 maps to target 3, unit 1 maps to target 1, and so on.
- security-#badlogins
- Number of incorrect security password attempts.This property has no special meaning or behavior on IA based systems.
- security-mode
- Firmware security level (options: none, command, or full). If set to command or full, system will prompt for PROM security
password. Defaults to none.This property has no special meaning or behavior on IA based systems.
- security-password
- Firmware security password (never displayed). Can be set only when security-mode is set to command or full.This property has no special meaning or behavior on IA based systems.
|
example# eeprom security-password=
Changing PROM password:
New password:
Retype new password:
|
- selftest-#megs
- Megabytes of RAM to test. Ignored if diag-switch? is true. Defaults to 1.
- sir-sync?
- Specify true to invoke OpenBoot PROM's sync word after a software-initiated reset (SIR) trap. Defaults to false. (Sun Enterprise 10000 only.)
- skip-vme-loopback?
- If true, POST does not do VMEbus loopback tests. Defaults to false.
- st-targets
- Map SCSI tape units (OpenBoot PROM version 1.x only). Defaults to 45670123, which means that unit 0 maps to target 4, unit 1 maps to target 5, and so on.
- sunmon-compat?
- If true, display Restricted Monitor prompt (>). Defaults to false.
- testarea
- One-byte scratch field, available for read/write test. Defaults to 0.
- tpe-link-test?
- Enable 10baseT link test for built-in twisted pair Ethernet. Defaults to true.
- ttya-mode
-
TTYA (baud rate, #bits, parity, #stop, handshake). Defaults to 9600,8,n,1,-.
Fields, in left-to-right order, are:
- Baud rate:
- 110, 300, 1200, 4800, 9600...
- Data bits:
- 5, 6, 7, 8
- Parity:
- n(none), e(even), o(odd), m(mark), s(space)
- Stop bits:
- 1, 1.5, 2
- Handshake:
- -(none), h(hardware:rts/cts), s(software:xon/xoff)
- ttyb-mode
-
TTYB (baud rate, #bits, parity, #stop, handshake). Defaults to 9600,8,n,1,-.
Fields, in left-to-right order, are:
- Baud rate:
- 110, 300, 1200, 4800, 9600...
- Data bits:
- 5, 6, 7, 8
- Stop bits:
- 1, 1.5, 2
- Parity:
- n(none), e(even), o(odd), m(mark), s(space)
- Handshake:
- -(none), h(hardware:rts/cts), s(software:xon/xoff)
- ttya-ignore-cd
- If true, operating system ignores carrier-detect on TTYA. Defaults to true.
- ttyb-ignore-cd
- If true, operating system ignores carrier-detect on TTYB. Defaults to true.
- ttya-rts-dtr-off
- If true, operating system does not assert DTR and RTS on TTYA. Defaults to false.
- ttyb-rts-dtr-off
- If true, operating system does not assert DTR and RTS on TTYB. Defaults to false.
- use-nvramrc?
- If true, execute commands in NVRAMRC during system start-up. Defaults to false.
- version2?
- If true, hybrid (1.x/2.x) PROM comes up in version 2.x. Defaults to true.
- watchdog-reboot?
- If true, reboot after watchdog reset. Defaults to false.
- watchdog-sync?
- Specify true to invoke OpenBoot PROM's sync word after a watchdog reset trap. Defaults to false. ( Sun Enterprise 10000 only.)
- xir-sync?
- Specify true to invoke OpenBoot PROM's sync word after an XIR trap. Defaults to false. (Sun Enterprise 10000 only.)
|
| Example 1. Changing the Number of Megabytes of RAM.
|
The following example demonstrates the method for changing from one to two the number of megabytes of RAM that the system will test.
|
example# eeprom selftest-#megs
selftest-#megs=1
example# eeprom selftest-#megs=2
example# eeprom selftest-#megs
selftest-#megs=2
|
|
Example 2. Setting the auto-boot? Parameter to true.
|
The following example demonstrates the method for setting the auto-boot? parameter to true.
|
example# eeprom auto-boot?=true
|
When the eeprom command is executed in user mode, the parameters with a trailing question mark (?) need to be enclosed in double quotation marks (" ") to prevent the shell from interpreting the question mark. Preceding the question mark with an escape character (\) will also prevent the shell from interpreting the question mark.
|
example% eeprom "auto-boot?"=true
|
|
Example 3. Enabling and Disabling PAE Mode
|
Certain IA machines support Physical Address Extension (PAE) mode. To enable and disable PAE mode on these machines, use commands such as those below.
To enable PAE mode:
|
example# eeprom mmu-modlist=mmu36
|
To disable PAE mode:
|
example# eeprom mmu-modlist=mmu32
|
These commands take effect following your next reboot.
|
|
|
-
/dev/openprom
- Device file
-
/usr/platform/platform-name/sbin/eeprom
- Platform-specific version of eeprom. Use uname -i to obtain platform-name.
|
|
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWcsu |
|
| |