|
System Administration Commands | groupadd(1M) |
| groupadd - add (create) a new group definition on the system |
SYNOPSIS
| /usr/sbin/groupadd [ -g gid [-o] ] group |
|
The groupadd command creates a new group definition on the system by adding the appropriate entry to the /etc/group file.
|
|
The following options are supported:
- -g gid
- Assigns the group id gid for the new
group. This group id must be a non-negative decimal integer below MAXUID as defined in /usr/include/sys/param.h. The group ID defaults to the next available (unique) number above the highest number currently assigned. For example, if groups 100, 105, and 200
are assigned as groups, the next default group number will be 201. (Group IDs from 0-99 are reserved by
SunOS for future applications.)
- -o
- Allows the gid to be duplicated (non-unique).
|
|
The following operands are supported:
-
group
- A string consisting of characters from the set of lower case alphabetic characters
and numeric characters. A warning message will be written if the string exceeds MAXGLEN, which is usually set at eight characters. The group
field must contain at least one character; it accepts lower case or numeric characters or a combination of both, and must not contain a colon (:) or NEWLINE.
|
|
The following exit values are returned:
-
0
- Successful completion.
-
2
- Invalid command syntax. A usage message for the groupadd command is displayed.
-
3
- An invalid argument was provided to an option.
-
4
- The gid is not unique (when -o option is not used).
-
9
- The group is not unique.
-
10
- The /etc/group file cannot be updated.
|
|
-
/etc/group
-
-
/usr/include/userdefs.h
-
|
|
See attributes(5) for descriptions of the following
attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWcsu |
|
|
users(1B), groupdel(1M), groupmod(1M), grpck(1M), logins(1M), pwck(1M), useradd(1M), userdel(1M), usermod(1M), group(4), attributes(5)
|
|
groupadd only adds a group definition to the local system. If a network name service such as NIS or NIS+ is being
used to supplement the local /etc/group file with additional entries, groupadd cannot change information supplied by the network name service. However, groupadd will verify the uniqueness of group name and group ID against the external name service.
|
| |